Saturday, February 21, 2009

openSUSE 11.1 - 32bit -> 64bit upgrade not so smooth

I recently upgraded a 64 bit machine that was running a 32 bit version of openSUSE 10.3. I upgraded it to 11.1. Yes, I know this is a jump of two versions. The update didn't entirely hose the machine, but tons of stuff was left as i586 instead of x86_64, including a bunch of pam stuff. Thus, ssh did not work. LOTS of stuff didn't work. Like half of YaST2. Once I was able to get in, a 'zypper dup' sorted out *some* of the problems, but not all of them. As I write this I'm still in the process of un-hosing the machine... UPDATE: it's basically unhosed. kudateapplet was missing a dependancy on kdelibs4 (or perhaps one of it's dependencies. Oh well. It's working great now!

No comments: